Skip to main content
← All vulnerabilities
CVE-2026-67321GHSA-HCPX-6FM6-WX23

axios 0.31.1 before 0.33.0 and 1.15.1 before 1.18.0 Denial of Service via maxDepth bypass

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 0.33.0, 1.18.0
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: poc
  • Automatable: yes
  • Technical impact: partial

Summary

axios versions 0.31.1 before 0.33.0 and 1.15.1 before 1.18.0 contain an incomplete depth-limit bypass in toFormData.js when serializing objects with top-level keys ending in '{}'. Attackers who control object keys and nested values passed to axios form or parameter serialization can trigger a RangeError from JSON.stringify, causing denial of service in the affected request path.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: poc · Automatable: yes · Technical impact: partial

  3. Record last updated

Affected versions

  • axios axios

    From 0.31.1 · fixed in 0.33.0

  • axios axios

    From 1.15.1 · fixed in 1.18.0

  • axiosnpm

    From 0.31.1 · fixed in 0.33.0

  • axiosnpm

    From 1.15.1 · fixed in 1.18.0

References 2

GitHub · axios/axios

vulncheck.com