Skip to main content
← All vulnerabilities
CVE-2026-65637GHSA-F525-44XV-F2QJ

Apache Tomcat: HTTP/2 no-authority bypass of strict SNI validation - CVE-2026-32990 fix incomplete

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 11.0.25, 10.1.59, 9.0.121
None on Exploit-DB, Metasploit or GitHub

Summary

Improper Input Validation vulnerability in Apache Tomcat due to incomplete fix for CVE-2026-32990. This issue affects Apache Tomcat: from 11.0.20 through 11.0.24, from 10.1.53 through 10.1.57, from 9.0.115 through 9.0.120. Users are recommended to upgrade to version 11.0.25, 10.1.58 or 9.0.121, which fix the issue.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • Apache Software Foundation Apache Tomcat

    From 11.0.20 · through 11.0.24; From 10.1.53 · through 10.1.57; From 9.0.115 · through 9.0.120

  • org.apache.tomcat:tomcat-coyoteMaven

    From 11.0.20 · fixed in 11.0.25

  • org.apache.tomcat:tomcat-coyoteMaven

    From 10.1.53 · fixed in 10.1.59

  • org.apache.tomcat:tomcat-coyoteMaven

    From 9.0.115 · fixed in 9.0.121

  • org.apache.tomcat.embed:tomcat-embed-coreMaven

    From 11.0.20 · fixed in 11.0.25

  • org.apache.tomcat.embed:tomcat-embed-coreMaven

    From 10.1.53 · fixed in 10.1.59

  • org.apache.tomcat.embed:tomcat-embed-coreMaven

    From 9.0.115 · fixed in 9.0.121

References 1

lists.apache.org