Skip to main content
← All vulnerabilities
CVE-2026-65608GHSA-C4WF-2XXC-68QM

Grav before 2.0.9 Remote Code Execution via FlexDirectory

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.0.9
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: poc
  • Automatable: no
  • Technical impact: total

Summary

Grav versions >= 1.7.0 and before 2.0.9 contain a remote code execution vulnerability. FlexDirectory::dynamicDataField() resolves blueprint data-*@: directives by calling call_user_func_array() on attacker-influenced input, validating only that the target is callable (is_callable()) without restricting dangerous functions such as exec, system, passthru, or shell_exec. Because FlexDirectory registers this handler for every Flex directory, it bypasses the validation added to Blueprint::dynamicData() in 2.0.7 (GHSA-fj2p-qj2f-74v5). Any authenticated user with create or update permission on any Flex-based directory (Flex Users, Flex Pages, Flex Objects, or custom Flex types) can execute arbitrary shell commands on the server.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: poc · Automatable: no · Technical impact: total

  3. Record last updated

Affected versions

  • getgrav grav

    From 1.7.0 · fixed in 2.0.9

  • getgrav/gravPackagist

    From 1.7.0 · fixed in 2.0.9

References 3

GitHub · getgrav/grav

vulncheck.com