Skip to main content
← All vulnerabilities
CVE-2026-6515

Insufficient Session Expiration in GitLab

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 18.9.6, 18.10.4, 18.11.1
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 18.2 before 18.9.6, 18.10 before 18.10.4, and 18.11 before 18.11.1 that could have allowed a user to use invalidated or incorrectly scoped credentials to access Virtual Registries under certain conditions.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • GitLab GitLab

    From 18.2 · fixed in 18.9.6; From 18.10 · fixed in 18.10.4; From 18.11 · fixed in 18.11.1

References 2

gitlab.com

about.gitlab.com