Skip to main content
← All vulnerabilities
CVE-2026-6479

PostgreSQL SSL/GSS init causes denial of service, via uncontrolled recursion

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 18.4, 17.10, 16.14, 15.18, 14.23
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: yes
  • Technical impact: partial

Summary

Uncontrolled recursion in PostgreSQL SSL and GSS negotiation allows an attacker able to connect to a PostgreSQL AF_UNIX socket to achieve sustained denial of service. If SSL and GSS are both disabled, an attacker can do the same via access to a PostgreSQL TCP socket. Versions before PostgreSQL 18.4, 17.10, 16.14, 15.18, and 14.23 are affected.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: yes · Technical impact: partial

  3. Record last updated

Affected versions

  • n/a PostgreSQL

    From 18 · fixed in 18.4; From 17 · fixed in 17.10; From 16 · fixed in 16.14; From 15 · fixed in 15.18; fixed in 14.23

References 1

postgresql.org