Skip to main content
← All vulnerabilities
CVE-2026-6365DRUPAL-CORE-2026-001BIT-DRUPAL-2026-6365GHSA-F3CJ-MJQM-FHVJ

Drupal core - Critical - Cross-site scripting - SA-CORE-2026-001

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 10.5.9, 10.6.7, 11.2.11, 11.3.7
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

Improper Neutralization of Input During Web Page Generation ("Cross-site Scripting") vulnerability in Drupal Drupal core allows Cross-Site Scripting (XSS). This issue affects Drupal core: from 8.0.0 before 10.5.9, from 10.6.0 before 10.6.7, from 11.0.0 before 11.2.11, from 11.3.0 before 11.3.7.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • Drupal Drupal core

    From 8.0.0 · fixed in 10.5.9; From 10.6.0 · fixed in 10.6.7; From 11.0.0 · fixed in 11.2.11; From 11.3.0 · fixed in 11.3.7

  • drupal/corePackagist

    From 8.0.0 · fixed in 10.5.9; From 10.6.0 · fixed in 10.6.7; From 11.0.0 · fixed in 11.2.11; From 11.3.0 · fixed in 11.3.7

  • drupal/corePackagist

    From 8.0.0 · fixed in 10.5.9

  • drupal/corePackagist

    From 10.6.0 · fixed in 10.6.7

  • drupal/corePackagist

    From 11.0.0 · fixed in 11.2.11

  • drupal/corePackagist

    From 11.3.0 · fixed in 11.3.7

References 1

drupal.org