Skip to main content
← All vulnerabilities
CVE-2026-6346GO-2026-5293GHSA-9P64-JPC7-M2RP

Sensitive credentials exposed in plaintext in Mattermost support packets

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 10.11.14+incompatible, 11.4.4+incompatible, 11.5.2+incompatible, 8.0.0-20260326202606-fac92f4a71f3, 11.5.2, and 3 more
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: total

Summary

Mattermost versions 11.5.x <= 11.5.1, 10.11.x <= 10.11.13, 11.4.x <= 11.4.3 fail to sanitize sensitive configuration fields before including them in support packet generation, which allows a Mattermost System Admin or any party with access to a support packet to obtain sensitive credentials in plaintext via downloading a support packet from the System Console.. Mattermost Advisory ID: MMSA-2026-00607

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: total

  3. Record last updated

Affected versions

  • Mattermost Mattermost

    From 11.5.0 · through 11.5.1; From 10.11.0 · through 10.11.13; From 11.4.0 · through 11.4.3

  • github.com/mattermost/mattermost-serverGo

    From 10.11.0+incompatible · fixed in 10.11.14+incompatible; From 11.4.0+incompatible · fixed in 11.4.4+incompatible; From 11.5.0+incompatible · fixed in 11.5.2+incompatible

  • github.com/mattermost/mattermost-server/v5Go

    All versions

  • github.com/mattermost/mattermost-server/v6Go

    All versions

  • github.com/mattermost/mattermost/server/v8Go

    fixed in 8.0.0-20260326202606-fac92f4a71f3

  • github.com/mattermost/mattermost/server/v8Go

    From 11.5.0 · fixed in 11.5.2

  • github.com/mattermost/mattermost/server/v8Go

    From 10.11.0 · fixed in 10.11.14

  • github.com/mattermost/mattermost/server/v8Go

    From 11.4.0 · fixed in 11.4.4

  • github.com/mattermost/mattermost-serverGo

    fixed in 5.3.2-0.20260326202606-fac92f4a71f3

References 1

mattermost.com